...pudding - diary


2013-08-06

_ [Software] Oracle の upgrade するときは COMPATIBLE の設定を忘れるな

Oracle の DB を upgrade したくて (10g→11g) アップグレードのスクリプトを流すと、DB が OPEN してないってエラーでアップグレードが継続できないんだけど、と問われて。

インスタンスを startup upgrade で起動してね、と伝えたのだけど、それだけではやっぱりダメで同じところでエラーになって。

インスタンス起動試行直後に COMPATIBLE をセットしておけとのメッセージが出ていた。どうやら初期値は導入中のバージョンとだいたい同じらしい。

旧DBのバージョンのモノも使えるようにパラメータファイルに COMPATIBLE=10.2.0 と指定しておいて解決。


2013年
8月
1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 31
Twitter : @moriya_jp